Welcome, Guest
Username: Password: Secret Key Remember me
Welcome to the Renault Kadjar Forum!

Tell us and our members who you are, what you like and why you became a member of this site.
We welcome all new members and hope to see you around a lot!
  • Page:
  • 1
  • 2

TOPIC: Display

Display 11 months 2 weeks ago #1

  • kadjar122
  • kadjar122's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 1
  • Thank you received: 0
Hi I have recently bought a 2018 reg, Kadjar my question is has anyone had their speedo display  change by itself  ?, I set mine to option 1 but on some days it has changed to op, 3 when starting the next day. !
Gordon

Please Log in or Create an account to join the conversation.

Display 11 months 2 weeks ago #2

  • stina
  • stina's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 7
  • Thank you received: 2
Hi

Yes. I have had car for two years and it always happens when weather goes cold - minus degrees. Have told it to dealer. They did some sort of update and told, that battery was low. I don't think it is a low battery problem and the update didn't help either. During next maintenance I will complain again, because it is very annoying. It does not reset only speedo display, but also driving statistics - range etc.
The following user(s) said Thank You: kadjar122

Please Log in or Create an account to join the conversation.

Display 11 months 2 weeks ago #3

  • turboted10
  • turboted10's Avatar
  • Offline
  • Elite Member
  • Elite Member
  • Posts: 284
  • Karma: 10
  • Thank you received: 26
One of the few system issues I haven't had. Mine are RLink related and setting/warnings etc etc are often lost/ changed without any driver input. Does RLink integrate in anyway with the dash and fuel computer? I have no idea. The dealers response is the same however, "never heard of that before, we'll do a reset", it never works. Mine is 25 months old, mot exactly an early car but all similar idiosyncrasies seem to be with 65/66 plte cars.
The following user(s) said Thank You: kadjar122

Please Log in or Create an account to join the conversation.

Display 11 months 2 weeks ago #4

  • AOne
  • AOne's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 633
  • Karma: 18
  • Thank you received: 157
This problem is basically related to faulty battery going flat or anytime soon - dead. 
1.6 dCI, 2WD, Zen+ , Retractable Tow Bar.
RLink 2 - V3.3.16.961, Here Maps (2019/Q2) + TomTom POIs and SpeedCams (2019_06)
The following user(s) said Thank You: kadjar122

Please Log in or Create an account to join the conversation.

Display 10 months 1 week ago #5

  • stina
  • stina's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 7
  • Thank you received: 2
I visited dealer for maintenance today. It is not battery problem. It looks like it is a hardware problem, because they are going to change whole instrument panel on my Kadjar. So I am waiting for the parts at the moment. Weäll see if that helps. :)

Please Log in or Create an account to join the conversation.

Display 10 months 1 week ago #6

  • turboted10
  • turboted10's Avatar
  • Offline
  • Elite Member
  • Elite Member
  • Posts: 284
  • Karma: 10
  • Thank you received: 26
You aren't the1st, several folks on here had the panel changed.
The following user(s) said Thank You: kadjar122

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.065 seconds