Welcome, Guest
Username: Password: Secret Key Remember me
  • Page:
  • 1

TOPIC:

Injector issue 7 months 1 week ago #1

  • andywilliams1187
  • andywilliams1187's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 10
  • Thank you received: 1
Hi all, 
Hoping for some help/guidance - My car is a 67 plate Kadjar 1.5 DCI Dynamique 

I was driving back from Newcastle (UK) to Liverpool yesterday - driving down a dual carriageway with the cruise control set at 75 - whole dashboard lit up and had a large loss of power. Had the following messages:
Check Hill Start Assist
Check Braking System
Check Injection
Check Anti-Pollution System

AA came out to rescue me (which was an absolute shocking experience and took 9 hours altogether). Tech plugged ob2 reader into the car and said there was a fault with number 2 injector (which makes sense as there was a noticeable loss of power and car was very sluggish at low revs). Eventrually towed me home. 
Car is now running fine (all warning lights have gone out, car is revving and driving normally). 
The car is still under extended warranty and is due to be looked at on the 02nd November, but I am concerned that if there are no faults, the same will happen again when the car is out of warranty (my extended warranty ends January 29th). 

When I spoke with the AA tech, he said that it could be the injector is failing when at temprature, but when I take it in, make sure I tell Renault that it is cylinder 2 and if they can't find the fault, tell them to check the resistance across all of the injectors. 

Has anyone had any similar issues? I am using my car at the moment for local trups (not risking motorway or anything) and the car has been up to temp but no faults/warning lights

Please Log in or Create an account to join the conversation.

Re:Injector issue 7 months 1 week ago #2

  • dynav18
  • dynav18's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 8
  • Thank you received: 1
My 2018 had one of the injectors replaced this year by my non Renault mechanic after engine light came on.

Sent from my moto g(8) plus using Tapatalk

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.100 seconds