General Engine & Technical Discussions

Discussion of the Renault Kadjar Engine, Transmission, and Drivetrain.

ANYTHING TO DO WITH THE 1.2 TCE SHOULD BE POSTED IN THE SEPARATE THREAD SPECIFICALLY CREATED FOR THIS ENGINE
Subject Replies Views Last Post

Say Hello

Last Post 2 years 1 month ago
by jolly
3 Replies 1525 Views jolly's Avatar
Last Post by jolly 2 years 1 month ago
 

How to disable ESP

Last Post 1 month 4 days ago
by AOne
8 Replies 3435 Views AOne's Avatar
Last Post by AOne 1 month 4 days ago

Ticking sound engine right side

Last Post 1 month 1 week ago
by jptib
0 Replies 103 Views jptib's Avatar
Last Post by jptib 1 month 1 week ago

Squeaks when moving from 1st to 2nd, 2nd to 3rd gear

Last Post 1 month 2 weeks ago
by gilnis2
0 Replies 1026 Views gilnis2's Avatar
Last Post by gilnis2 1 month 2 weeks ago

passenger's seat belt - problem

Last Post 2 months 1 week ago
by kingo
0 Replies 159 Views kingo's Avatar
Last Post by kingo 2 months 1 week ago

1.3 TCe 160 - are these rattling/hissing sounds normal?

Last Post 2 months 3 weeks ago
by AUkadjhelp
0 Replies 987 Views AUkadjhelp's Avatar
Last Post by AUkadjhelp 2 months 3 weeks ago

Grinding noise some seconds after starting.

Last Post 3 months 1 week ago
by AOne
13 Replies 2848 Views AOne's Avatar
Last Post by AOne 3 months 1 week ago

2018 1.5 Diesel Random Fault lights on dash

Last Post 3 months 3 weeks ago
by cus_tel
0 Replies 338 Views cus_tel's Avatar
Last Post by cus_tel 3 months 3 weeks ago

Check parking brake .cannot manually turn on brake

Last Post 3 months 3 weeks ago
by becchir2003
1 Replies 1153 Views becchir2003's Avatar
Last Post by becchir2003 3 months 3 weeks ago

"Check parking aid" sensor issue

Last Post 4 months 3 weeks ago
by Renaultidea
1 Replies 519 Views Renaultidea's Avatar
Last Post by Renaultidea 4 months 3 weeks ago

error P1493

Last Post 5 months 1 week ago
by yos1111
1 Replies 668 Views yos1111's Avatar
Last Post by yos1111 5 months 1 week ago

timing belt replace

Last Post 5 months 1 week ago
by yos1111
0 Replies 441 Views yos1111's Avatar
Last Post by yos1111 5 months 1 week ago

1.6dci 6 speed manual a little bit stick at ~1900 rmp

Last Post 6 months 2 weeks ago
by Szpilu_Hungary
2 Replies 1556 Views Szpilu_Hungary's Avatar
Last Post by Szpilu_Hungary 6 months 2 weeks ago

Tuning mod tick.

Last Post 8 months 1 week ago
by Stiggy
4 Replies 1634 Views Stiggy's Avatar
Last Post by Stiggy 8 months 1 week ago

coolant

Last Post 8 months 2 weeks ago
by Ned104
3 Replies 1232 Views Ned104's Avatar
Last Post by Ned104 8 months 2 weeks ago

error p1493

Last Post 8 months 3 weeks ago
by yos1111
0 Replies 696 Views yos1111's Avatar
Last Post by yos1111 8 months 3 weeks ago

My service light has reset to 300 miles/400 MONTHS

Last Post 9 months 2 weeks ago
by Piggy22
1 Replies 857 Views Piggy22's Avatar
Last Post by Piggy22 9 months 2 weeks ago

1.5dci Engine misfire

Last Post 11 months 1 week ago
by rymacg
0 Replies 1296 Views rymacg's Avatar
Last Post by rymacg 11 months 1 week ago

Engine oil mystery

Last Post 11 months 3 weeks ago
by Paul
3 Replies 1127 Views Paul's Avatar
Last Post by Paul 11 months 3 weeks ago

Check Anti Pollution System

Last Post 11 months 3 weeks ago
by Blackjr
6 Replies 19.2k Views Blackjr's Avatar
Last Post by Blackjr 11 months 3 weeks ago
  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.277 seconds