Welcome, Guest
Username: Password: Secret Key Remember me
  • Page:
  • 1
  • 2

TOPIC: Sat Nav gone off

Sat Nav gone off 2 months 2 weeks ago #1

  • tynesider
  • tynesider's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 56
  • Thank you received: 9
Out today everything working normal, parked up for 30 minutes got back started up ok in everything normal except the whole of the R2 link/sat nav screen is dead.

Tried pressing a few buttons but no good, everything else working ok .

Any idea's guy's before I go to my local Renault dealer as maybe I have just pressed something wrong as not had the car long since new in April
2019 Silver 1.3 TCe Dynamic turbo petrol, manual,

Please Log in or Create an account to join the conversation.

Last edit: by tynesider.

Re:Sat Nav gone off 2 months 2 weeks ago #2

  • AOne
  • AOne's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 630
  • Karma: 18
  • Thank you received: 155
Long press the On/Off button for a reboot. If it doesn't help, better visit the dealer.

Sent from my SM-N950F using Tapatalk
1.6 dCI, 2WD, Zen+ , Retractable Tow Bar.
RLink 2 - V3.3.16.961, Here Maps (2019/Q2) + TomTom POIs and SpeedCams (2019_06)

Please Log in or Create an account to join the conversation.

Re:Sat Nav gone off 2 months 2 weeks ago #3

  • tynesider
  • tynesider's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 56
  • Thank you received: 9

AOne wrote: Long press the On/Off button for a reboot. If it doesn't help, better visit the dealer.

Sent from my SM-N950F using Tapatalk


Thanks just tried that for over a minute but nothing screen still blank showing no signs of life
2019 Silver 1.3 TCe Dynamic turbo petrol, manual,

Please Log in or Create an account to join the conversation.

Re:Re:Sat Nav gone off 2 months 2 weeks ago #4

  • Trak-X
  • Trak-X's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 20
  • Thank you received: 5

tynesider wrote:

AOne wrote: Long press the On/Off button for a reboot. If it doesn't help, better visit the dealer.

Sent from my SM-N950F using Tapatalk


Thanks just tried that for over a minute but nothing screen still blank showing no signs of life

Do you still have radio or the chime when you unlock the car? If yes, your screen might be off and DDT / Pyren might fix it.

Sent from my Pixel 3 XL using Tapatalk
1.6 dCi - 4WD - Brown (2016)

RLink 2 - V3.3.16.961
Here Maps (Q2/2019) / TomTom POIs / SpeedCams (06.2019)

Please Log in or Create an account to join the conversation.

Sat Nav gone off 2 months 2 weeks ago #5

  • rance2019
  • rance2019's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 1
  • Thank you received: 0
Same thing happened to me on my 2016 Kadjar– it’s happened three times – the first time everything was dead -sat nav and speedo – took it to the dealer and they took a week to fix it. The second time, just the sat nav was dead – took it to the dealer again and they fixed it in a couple of hours – told me they did a software update. Well here I am about two weeks later and its dead yet again. I’m now not so sure they did a software update – maybe just some sort of reset. I’ve tried the long press of the power button but no joy

Not sure if it’s worth disconnecting the battery to ‘hard’ reset it or will I cause more problems?
Is this a common problem?

An update to this post - had the car booked in but before I could get to the dealer I had a flat battery so needed to fit a new one. This obviously required me to disconnect the old battery - the net result is that the sat nav display is now working - so a 'hard' power reset seemed to fix it.
I'm still faced with the worry that there is still a potential fault that could re-occur (and with the warranty end date fast approaching !) - the local Renault garage are saying they can't do anything unless its 'faulty' when I take it in.

Please Log in or Create an account to join the conversation.

Last edit: by rance2019. Reason: fixed problem by disconnecting the battery

Sat Nav gone off 2 months 2 weeks ago #6

  • tynesider
  • tynesider's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 56
  • Thank you received: 9
Will take it to the dealer in the morning and no doubt they probably want to book it in ( closed today bank hol)

No when I start uo everything is normal speedo working fine etc but no start up chime from the sat/nav/R2 link the screen is just dead

No not mad on disconnecting the battery for a restart in case I loose everything ??

held the on/off button In for a minute but nothing, I hope this is not a common fault as when the guarantee runs out it will cost a fortune to fix
2019 Silver 1.3 TCe Dynamic turbo petrol, manual,

Please Log in or Create an account to join the conversation.

Last edit: by tynesider.
  • Page:
  • 1
  • 2
Time to create page: 0.061 seconds